CCNA - OSPF SINGLE AREA CONFIGURATION

 This lab is uploaded from user DoubleDS

 

 

This lab shows the configuration of router about OSPF SINGLE AREA technology.

The lab uploaded by the user "doubleds"

The goal of this lab is to be pinging between routers that belong to different layer 3 network segments . 

The configuration was implemented according to the topology showing the image.

 

 

 

 

R1

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
enable secret labbook123
!
username cisco privilege 15 password 0 cisco
!
spanning-tree mode pvst
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 description R1 to R2
 ip address 192.168.1.5 255.255.255.252
 no cdp enable
 clock rate 128000
!
interface Serial0/0/1
 description R1 to R3
 ip address 192.168.1.13 255.255.255.252
 no cdp enable
 clock rate 128000
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 192.168.1.4 0.0.0.3 area 0
 network 192.168.1.0 0.0.0.3 area 0
 network 192.168.1.12 0.0.0.3 area 0
!
ip classless
!
line con 0
 login local
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
--------------------------------------------------

 

R2

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
enable secret labbook123
!
username cisco privilege 15 password 0 cisco
!
spanning-tree mode pvst
!
interface FastEthernet0/0
 ip address 192.168.1.9 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 description R2 from R1
 ip address 192.168.1.6 255.255.255.252
!
interface Serial0/0/1
 description R2 from R4
 ip address 192.168.1.21 255.255.255.252
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 192.168.1.4 0.0.0.3 area 0
 network 192.168.1.8 0.0.0.3 area 0
 network 192.168.1.20 0.0.0.3 area 0
!
ip classless
!
line con 0
 login local
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
--------------------------------------------------

 

R3

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
enable secret labbook123
!
username cisco privilege 15 password 0 cisco
!
spanning-tree mode pvst
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 description R3 to R4
 ip address 192.168.1.17 255.255.255.252
 clock rate 128000
!
interface Serial0/0/1
 description R3 from R1
 ip address 192.168.1.14 255.255.255.252
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 192.168.1.16 0.0.0.3 area 0
 network 192.168.1.12 0.0.0.3 area 0
!
ip classless
!
line con 0
 password cisco
 login local
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
--------------------------------------------------

 

R4

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R4
!
enable secret labbook123
!
username cisco privilege 15 password 0 cisco
!
spanning-tree mode pvst
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 description R4 from R3
 ip address 192.168.1.18 255.255.255.252
!
interface Serial0/0/1
 description R4 to R2
 ip address 192.168.1.22 255.255.255.252
 clock rate 128000
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 192.168.1.20 0.0.0.3 area 0
 network 192.168.1.16 0.0.0.3 area 0
!
ip classless
!
line con 0
 login local
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end

 

 

 

 

 

Read 1671 times
Published in CCNA