MULTI OSPF AREAs CONFIGURATION

This lab is uploaded from user PanosP

 

 

 

 

 

Discontinuous OSPF Areas

In this lab we are showing how to configure Open Shortest Path First (OSPF) routing protocol to connect multiple discontinuous areas. As you can see from the network diagram we have two OSPF areas that are not directly connected to OSPF backbone area 0. There is also a discontinuity between two OSPF backbone areas.

 

Learning Objectives:

  • Understand OSPF design.
  • Understand and configure virtual links.
  • Configure tunnels to connect OSPF areas.

In the OSPF routing protocol all areas in an autonomous system must be physically connected to the backbone area (Area 0). In some cases, where this is not possible, you can use one of two methods to connect to the backbone through a non-backbone area known as a transit area, a virtual link, or a tunnel. Each of these methods has pluses and minuses.

 

Virtual Link

The most common and straightforward is to use a virtual-link. This area is known as a transit area, and must have full routing information; also it cannot be a stub area. This method is most commonly used to connect sub areas to the backbone area.

 

Tunnel

The second method is use a GRE tunnel to pass the OSPF routing information through. The tunnel method dose add overhead as it requires encrypting the data and adding header information to the packets being passed, although an advantage is the it can go through a stub area. This method is very useful when connecting discontinuous OSPF backbone areas.

 

Tasks:

  1. Configure router hostnames on all routers.
  2. Configure IP addresses on Fast Ethernet interfaces of all routers as shown on the network diagram.
  3. Configure IP addresses on Serial interfaces of all routers as shown on the network diagram.
  4. Configure frame relay on serial interface S0/0/0 of ASBR1 and ABR4 as shown on the network diagram.
  5. Configure all routers to be part of the OSPF routing process 100.
  6. Configure routers ASBR1 and ABR4 to advertise network 155.1.14.0/24 as OSPF area 14.
  7. Configure routers ASBR1 and ABR2 to advertise network 155.1.12.0/24 as OSPF area 0.
  8. Configure routers ABR3 and ABR4 to advertise network 155.1.34.0/24 as OSPF area 0.
  9. Configure routers ABR4 and ABR5 to advertise network 155.1.45.0/24 as OSPF area 45.
  10. Advertise network 150.1.40.0/24 as OSPF area 40.
  11. Advertise network 150.1.50.0/24 as OSPF area 50.
  12. Advertise network 150.1.101.0/24 as OSPF area 101.
  13. Advertise network 150.1.102.0/24 as OSPF area 102.
  14. Advertise network 150.1.103.0/24 as OSPF area 103.
  15. Advertise network 150.1.104.0/24 as OSPF area 104.
  16. Configure area 45 as a virtual link.
  17. Repair the discontinuous OSPF backbone area 0.
  18. Verify OSPF routes
  19. Configure R1 and ASBR1 to be part of the EIGRP routing protocol in AS-1.
  20. Configure the network 155.1.11.0/24 to be part of the EIGRP routing protocol AS-1.
  21. Redistribute EIGRP routes into OSPF.
  22. Redistribute OSPF routes into EIGRP.
  23. Verify full connectivity from and to all end devices.

 

 

 

ABR2

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ABR2
!
spanning-tree mode pvst
!
interface FastEthernet0/0
 ip address 155.1.12.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 150.1.102.1 255.255.255.0
 duplex auto
 speed auto
!
router ospf 100
 router-id 2.2.2.2
 log-adjacency-changes
 network 150.1.102.1 0.0.0.0 area 102
 network 155.1.12.2 0.0.0.0 area 0
!
ip classless
!
no cdp run
!
line con 0
line vty 0 4
 login
!
end

--------------------------------------------------

 

 

ABR3

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ABR3
!
spanning-tree mode pvst
!
interface FastEthernet0/0
 ip address 155.1.34.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 150.1.103.1 255.255.255.0
 duplex auto
 speed auto
!
router ospf 100
 router-id 3.3.3.3
 log-adjacency-changes
 network 150.1.103.1 0.0.0.0 area 103
 network 155.1.34.3 0.0.0.0 area 0
!
ip classless
!
no cdp run
!
line con 0
line vty 0 4
 login
!
end

--------------------------------------------------

 

 

ABR4

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ABR4
!
spanning-tree mode pvst
!
interface Tunnel14
 ip address 155.1.1.4 255.255.255.0
 tunnel source Serial0/0/0
 tunnel destination 155.1.14.1
!
interface FastEthernet0/0
 ip address 155.1.34.4 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 150.1.104.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 155.1.14.4 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 155.1.14.1 401 broadcast
 frame-relay map ip 155.1.14.4 401
 ip ospf network broadcast
 ipv6 ospf cost 781
!
interface Serial0/1/0
 ip address 155.1.45.4 255.255.255.0
 ipv6 ospf cost 781
!
router ospf 100
 router-id 4.4.4.4
 log-adjacency-changes
 area 45 virtual-link 5.5.5.5
 network 155.1.34.4 0.0.0.0 area 0
 network 155.1.1.0 0.0.0.255 area 0
 network 155.1.14.4 0.0.0.0 area 14
 network 155.1.45.0 0.0.0.255 area 45
 network 150.1.104.1 0.0.0.0 area 104
!
ip classless
!
no cdp run
!
line con 0
line vty 0 4
 login
!
end

-----------------------------------------------------------

 

 

ABR5

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ABR5
!
spanning-tree mode pvst
!
interface FastEthernet0/0
 ip address 150.1.50.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/1/0
 ip address 155.1.45.5 255.255.255.0
 clock rate 2000000
!
router ospf 100
 router-id 5.5.5.5
 log-adjacency-changes
 area 45 virtual-link 4.4.4.4
 network 150.1.50.0 0.0.0.255 area 50
 network 155.1.45.0 0.0.0.255 area 45
!
ip classless
!
line con 0
line vty 0 4
 login
!
end

-------------------------------------------------------

 

 

ASBR1

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ASBR1
!
spanning-tree mode pvst
!
interface Tunnel14
 ip address 155.1.1.1 255.255.255.0
 tunnel source Serial0/0/0
 tunnel destination 155.1.14.4
!
interface FastEthernet0/0
 ip address 155.1.12.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 150.1.101.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 155.1.14.1 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 155.1.14.1 104
 frame-relay map ip 155.1.14.4 104 broadcast
 ip ospf network broadcast
 ipv6 ospf cost 781
!
interface Serial0/1/0
 ip address 155.1.11.1 255.255.255.0
 ipv6 ospf cost 781
!
router eigrp 1
 redistribute ospf 100 metric 1 1 1 1 1
 network 155.1.11.0 0.0.0.255
 no auto-summary
!
router ospf 100
 router-id 1.1.1.1
 log-adjacency-changes
 redistribute eigrp 1 subnets
 network 155.1.12.1 0.0.0.0 area 0
 network 155.1.1.0 0.0.0.255 area 0
 network 155.1.14.1 0.0.0.0 area 14
 network 150.1.101.1 0.0.0.0 area 101
!
ip classless
!
no cdp run
!
line con 0
line vty 0 4
 login
!
end

--------------------------------------------------

 

 

R1

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
spanning-tree mode pvst
!
interface Loopback0
 ip address 155.1.41.1 255.255.255.240
!
interface Loopback1
 ip address 155.1.41.17 255.255.255.240
!
interface Loopback2
 ip address 155.1.41.33 255.255.255.240
!
interface FastEthernet0/0
 ip address 150.1.40.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/1/0
 ip address 155.1.11.2 255.255.255.0
 clock rate 2000000
!
router eigrp 1
 redistribute ospf 100 metric 1 1 1 1 1
 network 155.1.41.0 0.0.0.63
 network 155.1.11.0 0.0.0.255
 no auto-summary
!
router ospf 100
 log-adjacency-changes
 redistribute eigrp 1 subnets
 network 150.1.40.0 0.0.0.255 area 40
!
ip classless
!
line con 0
line vty 0 4
 login
!
end

 

 

 

 

 

 

 

 

 

 

 

 

 

Read 2027 times
Published in Routing