WAN CLOUD - FRAME RELAY, EIGRP

This lab is uploaded from user PanosP

 

 

 

 

 

 

WAN Cloud Using Frame-Relay applied to connect VLSM LANs using EIGRP

Frame-Relay

Frame relay is a standardized wide area network technology that specifies the physical and logical link layers of digital telecommunications channels using a packet switching methodology. Originally designed for transport across Integrated Services Digital Network (ISDN) infrastructure, it may be used today in the context of many other network interfaces.

Network providers commonly implement frame relay for voice (VoFR) and data as an encapsulation technique, used between local area networks (LANs) over a wide area network (WAN). Each end-user gets a private line (or leased line) to a frame relay node. The frame relay network handles the transmission over a frequently changing path transparent to all end-user extensively used WAN protocols. It is less expensive than leased lines and that is one reason for its popularity. The extreme simplicity of configuring user equipment in a frame relay network offers another reason for frame relay's popularity.

With the advent of Ethernet over fiber optics, MPLS, VPN and dedicated broadband services such as cable modem and DSL, the end may loom for the frame relay protocol and encapsulation. However many rural areas remain lacking DSL and cable modem services. In such cases, the least expensive type of non-dial-up connection remains a 64-kbit/s frame relay line. Thus a retail chain, for instance, may use frame relay for connecting rural stores into their corporate WAN.

EIGRP

Enhanced Interior Gateway Routing Protocol (EIGRP) is an advanced distance-vector routing protocol that is used on a computer network to help automate routing decisions and configuration. The protocol was designed by Cisco Systems as a proprietary protocol, available only on Cisco routers, but Cisco converted it to an open standard in 2013.

EIGRP follows a router to share information it knows about the network with neighbouring routers within the same logical area known as an autonomous system. Contrary to other well-known routing protocols, such as routing information protocol, EIGRP only shares information that a neighbouring router would not have, rather than sending all of its information. EIGRP is optimized to help reduce the workload of the router and the amount of data that needs to be transmitted between routers.

VLSM (CIDR)

Classless Inter-Domain Routing is a method for allocating IP addresses and routing Internet Protocol packets. The Internet Engineering Task Force introduced CIDR in 1993 to replace the previous addressing architecture of classful network design in the Internet. Its goal was to slow the growth of routing tables on routers across the Internet, and to help slow the rapid exhaustion of IPv4 addresses.

IP addresses are described as consisting of two groups of bits in the address: the most significant bits are the network address, which identifies a whole network or subnet, and the least significant set forms the host identifier, which specifies a particular interface of a host on that network. This division is used as the basis of traffic routing between IP networks and for address allocation policies. Classful network design for IPv4 sized the network address as one or more 8-bit groups, resulting in the blocks of Class A, B, or C addresses. Classless Inter-Domain Routing allocates address space to Internet service providers and end users on any address bit boundary, instead of on 8-bit segments. In IPv6, however, the interface identifier has a fixed size of 64 bits by convention, and smaller subnets are never allocated to end users.

CIDR notation is a syntax for specifying IP addresses and their associated routing prefix. It appends a slash character to the address and the decimal number of leading bits of the routing prefix, e.g., 192.168.2.0/24 for IPv4, and 2001:db8::/32 for IPv6.

 

 

FRAME RELAY CONFIGURATION

 

 

 

NET1

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname NET1
!
ip cef
no ipv6 cef
!
no ip domain-lookup
ip domain-name CCNA.com
!
spanning-tree mode rapid-pvst
!
interface GigabitEthernet0/0
 description **10 Hosts**Private Net**
 ip address 195.175.105.33 255.255.255.240
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description **5 Hosts**Private Net**
 ip address 195.175.105.49 255.255.255.248
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 description **2 Hosts**Private Net**
 ip address 195.175.105.57 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/0/0
 description **2 Hosts - Connected to R1**Public Net**
 ip address 209.170.120.193 255.255.255.252
 clock rate 2000000
!
router eigrp 10
 network 195.175.105.32 0.0.0.15
 network 195.175.105.48 0.0.0.7
 network 195.175.105.56 0.0.0.3
 network 209.170.120.192 0.0.0.3
 no auto-summary
!
ip classless
!
ip flow-export version 9
!
banner motd 
******************************************************
************ AUTHORISED ACCESS REQUIRED **************
******************************************************
* Unathorised access to this device is prohibited.   *
* You must have explicit permission to access this   *
* device. Any violation of access policy will result *
* in disciplinary action. !
line con 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line aux 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line vty 0 4
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
line vty 5 15
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
end

------------------------------------------------------------

 

 

 

NET2

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname NET2
!
ip cef
no ipv6 cef
!
no ip domain-lookup
ip domain-name CCNA.com
!
spanning-tree mode rapid-pvst
!
interface GigabitEthernet0/0
 description **40 Hosts**Private Net**
 ip address 172.16.4.129 255.255.255.192
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description **25 Hosts**Private Net**
 ip address 172.16.4.193 255.255.255.224
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 description **12 Hosts**Private Net**
 ip address 172.16.4.225 255.255.255.240
 duplex auto
 speed auto
!
interface Serial0/0/0
 description **2 Hosts - Connected to R2**Public Net**
 ip address 209.169.68.85 255.255.255.252
 clock rate 2000000
!
router eigrp 10
 network 172.16.4.128 0.0.0.63
 network 172.16.4.192 0.0.0.31
 network 172.16.4.224 0.0.0.15
 network 209.169.68.84 0.0.0.3
 no auto-summary
!
ip classless
!
ip flow-export version 9
!
banner motd 
******************************************************
************ AUTHORISED ACCESS REQUIRED **************
******************************************************
* Unathorised access to this device is prohibited.   *
* You must have explicit permission to access this   *
* device. Any violation of access policy will result *
* in disciplinary action.                            *
****************************************************** 
!
line con 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line aux 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line vty 0 4
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
line vty 5 15
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
end

----------------------------------------------------------

 

 

NET3

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname NET3
!
ip cef
no ipv6 cef
!
no ip domain-lookup
ip domain-name CCNA.com
!
spanning-tree mode rapid-pvst
!
interface GigabitEthernet0/0
 description ***30 Hosts - Private Network***
 ip address 192.168.112.65 255.255.255.224
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description ***14 Hosts - Private Network***
 ip address 192.168.112.97 255.255.255.240
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 description ***6 Hosts - Private Network***
 ip address 192.168.112.113 255.255.255.248
 duplex auto
 speed auto
!
interface Serial0/0/0
 description ***2 Hosts - Connected to R3**Public Net***
 ip address 209.175.180.205 255.255.255.252
 ip summary-address eigrp 10 209.175.180.204 255.255.255.252 5
 clock rate 2000000
!
router eigrp 10
 network 192.168.112.64 0.0.0.31
 network 192.168.112.96 0.0.0.15
 network 192.168.112.112 0.0.0.7
 network 209.175.180.204 0.0.0.3
 no auto-summary
!
ip classless
!
ip flow-export version 9
!
banner motd 
******************************************************
************ AUTHORISED ACCESS REQUIRED **************
******************************************************
* Unathorised access to this device is prohibited.   *
* You must have explicit permission to access this   *
* device. Any violation of access policy will result *
* in disciplinary action.                            *
****************************************************** 
!
line con 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line aux 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line vty 0 4
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
line vty 5 15
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
end

---------------------------------------------------

 

 

NET4

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname NET4
!
ip cef
no ipv6 cef
!
no ip domain-lookup
ip domain-name CCNA.com
!
spanning-tree mode rapid-pvst
!
interface GigabitEthernet0/0
 ip address 196.254.10.1 255.255.255.128
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 169.254.10.129 255.255.255.192
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 ip address 169.254.10.193 255.255.255.192
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 209.175.180.202 255.255.255.252
 ip summary-address eigrp 10 209.175.180.200 255.255.255.252 5
 clock rate 2000000
!
router eigrp 10
 network 169.254.10.128 0.0.0.63
 network 169.254.10.192 0.0.0.63
 network 209.175.180.200 0.0.0.3
 network 169.254.10.0 0.0.0.127
 no auto-summary
!
ip classless
!
ip flow-export version 9
!
no cdp run
!
banner motd 
******************************************************
************ AUTHORISED ACCESS REQUIRED **************
******************************************************
* Unathorised access to this device is prohibited.   *
* You must have explicit permission to access this   *
* device. Any violation of access policy will result *
* in disciplinary action.                            *
****************************************************** 
!
line con 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line aux 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line vty 0 4
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
line vty 5 15
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
end

------------------------------------------------

 

 

R1

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
ip cef
no ipv6 cef
!
no ip domain-lookup
ip domain-name CCNA.com
!
spanning-tree mode rapid-pvst
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 10.1.1.1 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 10.1.1.2 102 broadcast
 frame-relay map ip 10.1.1.3 103 broadcast
 clock rate 2000000
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/1/0
 description **2 Hosts - Connected to NET1**Public Net**
 ip address 209.170.120.194 255.255.255.252
 clock rate 2000000
!
interface Serial0/1/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 10
 network 209.170.120.192 0.0.0.3
 network 10.1.1.0 0.0.0.255
 auto-summary
!
ip classless
!
ip flow-export version 9
!
no cdp run
!
banner motd 
******************************************************
************ AUTHORISED ACCESS REQUIRED **************
******************************************************
* Unathorised access to this device is prohibited.   *
* You must have explicit permission to access this   *
* device. Any violation of access policy will result *
* in disciplinary action.                            *
****************************************************** 
!
line con 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line aux 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line vty 0 4
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
line vty 5 15
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
end

-------------------------------------------------------------

 

 

R2

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
ip cef
no ipv6 cef
!
no ip domain-lookup
ip domain-name CCNA.com
!
spanning-tree mode rapid-pvst
!
interface Serial0/0/0
 ip address 10.1.1.2 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 10.1.1.1 201 broadcast
 frame-relay map ip 10.1.1.3 203 broadcast
 clock rate 2000000
!
interface Serial0/0/1
 description **2 Hosts - Connected to NET2**Public Net**
 ip address 209.169.68.86 255.255.255.252
 clock rate 2000000
!
router eigrp 10
 network 209.169.68.84 0.0.0.3
 network 10.1.1.0 0.0.0.255
 auto-summary
!
ip classless
!
ip flow-export version 9
!
banner motd 
******************************************************
************ AUTHORISED ACCESS REQUIRED **************
******************************************************
* Unathorised access to this device is prohibited.   *
* You must have explicit permission to access this   *
* device. Any violation of access policy will result *
* in disciplinary action.                            *
****************************************************** 
!
line con 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line aux 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line vty 0 4
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
line vty 5 15
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
end

-------------------------------------------------------

 

 

R3

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
ip cef
no ipv6 cef
!
no ip domain-lookup
ip domain-name CCNA.com
!
spanning-tree mode rapid-pvst
!
interface Serial0/0/0
 ip address 10.1.1.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 10.1.1.1 301 broadcast
 frame-relay map ip 10.1.1.2 302 broadcast
 clock rate 2000000
!
interface Serial0/0/1
 ip address 209.175.180.206 255.255.255.252
 clock rate 128000
!
interface Serial0/1/0
 ip address 209.175.180.201 255.255.255.252
 clock rate 128000
!
router eigrp 10
 network 209.175.180.200 0.0.0.3
 network 209.175.180.204 0.0.0.3
 network 10.1.1.0 0.0.0.255
 no auto-summary
!
ip classless
!
ip flow-export version 9
!
banner motd 
******************************************************
************ AUTHORISED ACCESS REQUIRED **************
******************************************************
* Unathorised access to this device is prohibited.   *
* You must have explicit permission to access this   *
* device. Any violation of access policy will result *
* in disciplinary action.                            *
****************************************************** 
!
line con 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line aux 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line vty 0 4
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
line vty 5 15
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
end

 

 

 

 

 

 

Read 1968 times
Published in Service Provider