ROUTER - ROUTE MAP (Per Protocol)

 

This LAB presents the configuration of the technology route map in Cisco Router. 

The policy routing is applied in this lab is according to the protocols http and https.

The configuration was implemented according to the topology showing the image.

 

Router Model:   Cisco 886-K9 
Version IOS: 15.2
Subject: Configure route map (per protocol) on cisco routers
Category LAB: Routing

 

 

 

 

 CONFIGURATION OF ROUTER 1

 

hostname ROUTER-1

!

boot-start-marker

boot-end-marker

!

enable secret labbook123

!

ip cef

ip domain name labbook.gr

!

username labbook privilege 15 secret labbook123

!

!

interface FastEthernet0/1

 ip address 192.168.5.1 255.255.255.0

 ip nat inside

 ip virtual-reassembly

 ip policy route-map control-internet-traffic

 duplex auto

 speed auto

 no shutdown

!

interface ATM0/1/0

 no ip address

 no atm ilmi-keepalive

 no shutdown

!

interface ATM0/1/0.1 point-to-point

 pvc 8/35

   pppoe-client dial-pool-number 2

!

no shutdown

!

!

interface Dialer2

 description *** Public IP 85.85.85.35/32 ***

 ip nat outside

 no shutdown

!

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer2

!

!

ip http server

ip nat inside source list 199 interface Dialer2 overload

!

access-list 160 permit tcp host 192.168.5.10 any eq 80

access-list 160 permit tcp host 192.168.5.10 any eq 443

access-list 160 permit tcp host 192.168.5.11 any eq 80

access-list 160 permit tcp host 192.168.5.11 any eq 443

access-list 160 permit tcp host 192.168.5.12 any eq 80

access-list 160 permit tcp host 192.168.5.12 any eq 443

!

access-list 165 permit ip 192.168.5.0 0.0.0.255 any

!

access-list 199 permit ip 192.168.5.0 0.0.0.255 any

!

!

route-map control-internet-traffic permit 5

 match ip address 160

 set ip next-hop 192.168.5.2

!

route-map control-internet-traffic permit 10

 match ip address 165

 set interface Dialer2

!

!

!

control-plane

!

!

end

 

-----------------------------------------------------------------------------------------------------------------------------

CONFIGURATION OF ROUTER 2

 

hostname ROUTER-2

!

boot-start-marker

boot-end-marker

!

enable secret labbook123

!

ip cef

ip domain name labbook.gr

!

username labbook privilege 15 secret labbook123

!

!

interface FastEthernet0/1

ip address 192.168.5.2 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

no shutdown

!

interface ATM0/1/0

no ip address

no atm ilmi-keepalive

no shutdown

!

interface ATM0/1/0.1 point-to-point

pvc 8/35

  pppoe-client dial-pool-number 2

!

no shutdown

!

!

interface Dialer2

description *** Public IP 75.75.75.35/32 ***

ip nat outside

no shutdown

!

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer2

!

!

ip http server

ip nat inside source list 199 interface Dialer2 overload

!

access-list 199 permit ip 192.168.5.0 0.0.0.255 any

!

control-plane

!

!

end

Read 1038 times
Published in Routing