CCNA - RIPv2 and STATIC ROUTES CONFIGURATION

This lab is uploaded from user DoubleDS

 

 

This lab shows the configuration of router about RIPv2 and static routes simultaneously.

The lab uploaded by the user "doubleds"

The goal of this lab is to be pinging between routers that belong to different layer 3 network segments . 

The configuration was implemented according to the topology showing the image.

 

 

 ATHENS

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ATHENS
!
enable secret labbook123
!
ip host ATHENS 192.168.1.2
!
interface Loopback0
 ip address 10.10.10.0 255.255.0.0
!
interface FastEthernet0/0
 ip address 192.168.1.2 255.255.255.240
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.1.33 255.255.255.240
 duplex auto
 speed auto
!
interface FastEthernet2/0
 ip address 192.168.1.145 255.255.255.240
 duplex auto
 speed auto
!
router rip
 version 2
 network 192.168.1.0
!
ip classless
ip route 10.10.7.0 255.255.255.240 192.168.1.82
ip route 10.10.1.0 255.255.255.240 192.168.1.1
ip route 10.10.6.0 255.255.255.240 192.168.1.50
ip route 10.10.9.0 255.255.255.240 192.168.1.146
ip route 10.10.8.0 255.255.255.240 192.168.1.98
ip route 10.10.5.0 255.255.255.240 192.168.1.18
!
line con 0
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
--------------------------------------------------

 

BB

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname BB
!
enable secret labbook123
!
ip host BB 192.168.1.18
!
interface Loopback0
 ip address 10.10.5.0 255.255.0.0
!
interface FastEthernet0/0
 ip address 192.168.1.18 255.255.255.240
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.1.65 255.255.255.240
 duplex auto
 speed auto
!
interface FastEthernet2/0
 ip address 192.168.1.34 255.255.255.240
 duplex auto
 speed auto
!
router rip
 version 2
 network 192.168.1.0
 network 192.169.1.0
!
ip classless
ip route 10.10.6.0 255.255.255.240 192.168.1.50
ip route 10.10.7.0 255.255.255.240 192.168.1.82
ip route 10.10.10.0 255.255.255.240 192.168.1.2
ip route 10.10.1.0 255.255.255.240 192.168.1.1
ip route 10.10.9.0 255.255.255.240 192.168.1.146
ip route 10.10.8.0 255.255.255.240 192.168.1.98
!
line con 0
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
--------------------------------------------------

 

CRETA

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname CRETA
!
enable secret labbook123
!
ip host ATHENS 192.168.1.2
ip host BB 192.168.1.18
ip host CRETA 192.168.1.50
ip host INTERNET 192.168.1.146
ip host MYKONOS 192.168.1.81
ip host PAROS 192.168.1.98
ip host PATRA 192.168.1.17
ip host SW1 192.168.1.3
ip host SW2 192.168.1.67
ip host SW3 192.168.1.130
!
interface Loopback0
 ip address 10.10.6.0 255.255.0.0
!
interface FastEthernet0/0
 ip address 192.168.1.66 255.255.255.240
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.1.50 255.255.255.240
 duplex auto
 speed auto
!
interface FastEthernet2/0
 ip address 192.168.1.81 255.255.255.240
 duplex auto
 speed auto
!
router rip
 version 2
 network 192.168.1.0
!
ip classless
ip route 10.10.1.0 255.255.255.240 192.168.1.49
ip route 10.10.10.0 255.255.255.240 192.168.1.2
ip route 10.10.7.0 255.255.255.240 192.168.1.82
ip route 10.10.8.0 255.255.255.240 192.168.1.98
ip route 10.10.9.0 255.255.255.240 192.168.1.129
ip route 10.10.5.0 255.255.255.240 192.168.1.18
!
line con 0
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
--------------------------------------------------

 

INTERNET

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname INTERNET
!
enable secret labbook123
!
ip host INTERNET 192.168.1.146
!
interface Loopback0
 ip address 10.10.9.0 255.255.0.0
!
interface FastEthernet0/0
 ip address 192.168.1.146 255.255.255.240
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.1.113 255.255.255.240
 duplex auto
 speed auto
!
interface FastEthernet2/0
 ip address 192.168.1.129 255.255.255.240
 duplex auto
 speed auto
!
router rip
 version 2
 network 192.168.1.0
!
ip classless
ip route 10.10.6.0 255.255.255.240 192.168.1.50
ip route 10.10.7.0 255.255.255.240 192.168.1.82
ip route 10.10.10.0 255.255.255.240 192.168.1.2
ip route 10.10.1.0 255.255.255.240 192.168.1.1
ip route 10.10.8.0 255.255.255.240 192.168.1.98
ip route 10.10.5.0 255.255.255.240 192.168.1.18
!
no cdp run
!
line con 0
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
--------------------------------------------------

 

MYKONOS

version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname MYKONOS
!
enable secret labbook123
!
ip host MYKONOS 192.168.1.81
!
spanning-tree mode pvst
!
interface Loopback0
 ip address 10.10.7.0 255.255.0.0
!
interface FastEthernet0/0
 ip address 192.168.1.82 255.255.255.240
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.1.97 255.255.255.240
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport mode access
 shutdown
!
interface FastEthernet0/1/1
 switchport mode access
 shutdown
!
interface FastEthernet0/1/2
 switchport mode access
 shutdown
!
interface FastEthernet0/1/3
 switchport mode access
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 version 2
 network 192.168.1.0
!
ip classless
ip route 10.10.6.0 255.255.255.240 192.168.1.50
ip route 10.10.10.0 255.255.255.240 192.168.1.2
ip route 10.10.1.0 255.255.255.240 192.168.1.1
ip route 10.10.9.0 255.255.255.240 192.168.1.146
ip route 10.10.8.0 255.255.255.240 192.168.1.98
ip route 10.10.5.0 255.255.255.240 192.168.1.18
!
line con 0
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
--------------------------------------------------

 

PAROS

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname PAROS
!
enable secret labbook123
!
ip host PAROS 192.168.1.98
!
interface Loopback0
 ip address 10.10.8.0 255.255.0.0
!
interface FastEthernet0/0
 ip address 192.168.1.114 255.255.255.240
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.1.98 255.255.255.240
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
router rip
 version 2
 network 192.168.1.0
!
ip classless
ip route 10.10.6.0 255.255.255.240 192.168.1.50
ip route 10.10.7.0 255.255.255.240 192.168.1.82
ip route 10.10.10.0 255.255.255.240 192.168.1.2
ip route 10.10.1.0 255.255.255.240 192.168.1.1
ip route 10.10.9.0 255.255.255.240 192.168.1.146
ip route 10.10.5.0 255.255.255.240 192.168.1.18
!
line con 0
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
--------------------------------------------------

 

PATRA

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname PATRA
!
enable secret labbook123
!
interface Loopback0
 ip address 10.10.1.0 255.255.0.0
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.240
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.1.17 255.255.255.240
 duplex auto
 speed auto
!
interface FastEthernet2/0
 ip address 192.168.1.49 255.255.255.240
 duplex auto
 speed auto
!
router rip
 version 2
 network 192.168.1.0
!
ip classless
ip route 10.10.6.0 255.255.255.240 192.168.1.50
ip route 10.10.7.0 255.255.255.240 192.168.1.81
ip route 10.10.10.0 255.255.255.240 192.168.1.2
ip route 10.10.9.0 255.255.255.240 192.168.1.146
ip route 10.10.8.0 255.255.255.240 192.168.1.98
ip route 10.10.5.0 255.255.255.240 192.168.1.18
!
line con 0
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end

 

 

 

 

 

 

Read 1320 times
Published in CCNA