CCNA - OSPF, RIPv2, STATIC ROUTES, REDISTRIBUTING (complicated)

This lab is uploaded from user DoubleDS 

 

 

This lab shows the configuration of router about dynamic routing protocols technology. This lab includes RIPv2OSPF, static routes and redistributing route technology.

The lab uploaded by the user "doubleds"

The goal of this lab is to be pinging between routers that belong to different layer 3 network segments . 

The configuration was implemented according to the topology showing the image.

 

 

 

 

 

 

 

R1

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
enable secret labbook123
!
username cisco privilege 15 password 0 cisco
!
spanning-tree mode pvst
!
interface FastEthernet0/0
 description R1 connected R13
 ip address 10.10.10.65 255.255.255.192
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description R1 connected R2
 ip address 10.10.20.1 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 10.10.10.128 255.255.255.192 10.10.10.66
ip route 192.168.1.0 255.255.255.0 10.10.10.130
ip route 10.10.10.0 255.255.255.192 10.10.20.2
ip route 172.16.1.0 255.255.255.0 10.10.10.2
ip route 192.168.240.0 255.255.255.0 10.10.10.2
!
no cdp run
!
banner motd ^CBackbone GOD R1 i know you^C
!
line con 0
 login local
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
----------------------------------------------------

 

R2

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
enable secret labbook123
!
username cisco privilege 15 password 0 cisco
!
spanning-tree mode pvst
!
interface FastEthernet0/0
 description R2 connected R1
 ip address 10.10.20.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 description R2 from R8
 ip address 10.10.10.1 255.255.255.192
!
interface Serial0/0/1
 no ip address
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 10.10.10.64 255.255.255.192 10.10.20.1
ip route 10.10.10.128 255.255.255.192 10.10.10.66
ip route 192.168.1.0 255.255.255.0 10.10.10.130
ip route 172.16.1.0 255.255.255.0 10.10.10.2
ip route 172.16.1.0 255.255.255.224 10.10.10.2
ip route 192.168.240.0 255.255.255.0 10.10.10.2
!
no cdp run
!
banner motd ^CBackbone R2 ^C
!
line con 0
 login local
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
----------------------------------------------------

 

R3

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
enable secret labbook123
!
username cisco privilege 15 password 0 cisco
!
spanning-tree mode pvst
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 description R3 to R5
 ip address 192.168.1.33 255.255.255.240
 clock rate 128000
!
interface Serial0/0/1
 description R3 from R4
 ip address 192.168.1.49 255.255.255.240
!
interface Serial0/1/0
 description R3 to R6
 ip address 192.168.1.97 255.255.255.240
 clock rate 128000
!
interface Serial0/1/1
 no ip address
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 version 2
 network 192.168.1.0
 no auto-summary
!
ip classless
!
no cdp run
!
banner motd ^CHIS IS R3 WHO IS I^C
!
line con 0
 login local
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
----------------------------------------------------

 

R4

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R4
!
enable secret labbook123
!
username cisco privilege 15 password 0 cisco
!
spanning-tree mode pvst
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 description R4 from R6
 ip address 192.168.1.65 255.255.255.240
!
interface Serial0/0/1
 description R4 to R3
 ip address 192.168.1.50 255.255.255.240
 clock rate 128000
!
interface Serial0/1/0
 description R4 from R5
 ip address 192.168.1.82 255.255.255.240
!
interface Serial0/1/1
 description R4 to R13
 ip address 10.10.10.130 255.255.255.192
 clock rate 128000
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 version 2
 redistribute ospf 1
 redistribute static
 network 10.0.0.0
 network 192.168.1.0
!
ip classless
ip route 10.10.10.64 255.255.255.192 10.10.10.129
ip route 10.10.20.0 255.255.255.0 10.10.10.65
ip route 10.10.10.0 255.255.255.192 10.10.20.2
ip route 172.16.1.0 255.255.255.0 10.10.20.2
ip route 192.168.240.0 255.255.255.0 10.10.10.2
!
no cdp run
!
banner motd ^Cello this is R4
banner motd "^C
!
line con 0
 login local
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
----------------------------------------------------

 

R5

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R5
!
enable secret labbook123
!
username cisco privilege 15 password 0 cisco
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 description R5 rom R3
 ip address 192.168.1.34 255.255.255.240
!
interface Serial0/0/1
 description R5 to R6
 ip address 192.168.1.17 255.255.255.240
 clock rate 128000
!
interface Serial0/1/0
 description R5 to R4
 ip address 192.168.1.81 255.255.255.240
 clock rate 128000
!
interface Serial0/1/1
 no ip address
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 version 2
 network 192.168.1.0
 no auto-summary
!
ip classless
!
no cdp run
!
banner motd ^CTHIS IS R5 WHO IS IT^C
!
line con 0
 login local
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
----------------------------------------------------

 

R6

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R6
!
enable secret labbook123
!
username cisco privilege 15 password 0 cisco
!
spanning-tree mode pvst
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.240
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 description R6 from R5
 ip address 192.168.1.18 255.255.255.240
!
interface Serial0/0/1
 description R6 to R4
 ip address 192.168.1.66 255.255.255.240
!
interface Serial0/1/0
 description R6 from R3
 ip address 192.168.1.98 255.255.255.240
!
interface Serial0/1/1
 no ip address
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 version 2
 network 192.168.1.0
 no auto-summary
!
ip classless
!
no cdp run
!
banner motd ^C THIS IS R6 WHO IS IT ^C
!
line con 0
 login local
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
----------------------------------------------------

 

R8

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R8
!
enable secret labbook123
!
username cisco privilege 15 password 0 cisco
!
spanning-tree mode pvst
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 description R8 to R2
 ip address 10.10.10.2 255.255.255.192
 clock rate 128000
!
interface Serial0/0/1
 description R8 from R10
 ip address 172.16.1.34 255.255.255.224
!
interface Serial0/1/0
 description R8 to R9
 ip address 172.16.1.65 255.255.255.224
 clock rate 128000
!
interface Serial0/1/1
 description R8 from R11
 ip address 172.16.1.193 255.255.255.224
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 redistribute rip subnets
 redistribute static subnets
 network 172.16.1.32 0.0.0.31 area 0
 network 172.16.1.192 0.0.0.31 area 0
 network 172.16.1.64 0.0.0.31 area 0
 default-information originate
!
ip classless
ip route 10.10.20.0 255.255.255.0 10.10.10.1
ip route 10.10.10.64 255.255.255.192 10.10.20.1
ip route 10.10.10.128 255.255.255.192 10.10.10.66
ip route 192.168.1.0 255.255.255.0 10.10.10.130
!
no cdp run
!
banner motd ^CR8 Warning!! Restricted OSPF Area 0^C
!
line con 0
 login local
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
----------------------------------------------------

 

R9

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R9
!
enable secret labbook123
!
username cisco privilege 15 password 0 cisco
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 description R9 from R8
 ip address 172.16.1.66 255.255.255.224
!
interface Serial0/0/1
 description R9 to R11
 ip address 172.16.1.130 255.255.255.224
 clock rate 128000
!
interface Serial0/1/0
 description R9 to R10
 ip address 172.16.1.161 255.255.255.224
 clock rate 128000
!
interface Serial0/1/1
 description R9 from R12
 ip address 192.168.240.1 255.255.255.192
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 172.16.1.64 0.0.0.31 area 0
 network 172.16.1.160 0.0.0.31 area 0
 network 172.16.1.128 0.0.0.31 area 0
 network 192.168.240.0 0.0.0.63 area 1
!
ip classless
!
no cdp run
!
banner motd ^CR9 Border Area 0,1^C
!
line con 0
 login local
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
----------------------------------------------------

 

R10

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
enable secret labbook123
!
username cisco privilege 15 password 0 cisco
!
spanning-tree mode pvst
!
interface FastEthernet0/0
 ip address 172.16.1.1 255.255.255.224
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 description R10 to R8
 ip address 172.16.1.33 255.255.255.224
 clock rate 128000
!
interface Serial0/0/1
 description R10 from R11
 ip address 172.16.1.97 255.255.255.224
!
interface Serial0/1/0
 description R10 from R9
 ip address 172.16.1.162 255.255.255.224
!
interface Serial0/1/1
 no ip address
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 172.16.1.0 0.0.0.31 area 0
 network 172.16.1.32 0.0.0.31 area 0
 network 172.16.1.160 0.0.0.31 area 0
 network 172.16.1.96 0.0.0.31 area 0
!
ip classless
!
no cdp run
!
banner motd ^CR10 Welcome To www.Cisco_InterNetwork.com^C
!
line con 0
 login local
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
----------------------------------------------------

 

R11

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R11
!
enable secret labbook123
!
username cisco privilege 15 password 0 cisco
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 description R11 from R9
 ip address 172.16.1.129 255.255.255.224
!
interface Serial0/0/1
 description R11 to R10
 ip address 172.16.1.98 255.255.255.224
 clock rate 128000
!
interface Serial0/1/0
 description R11 to R8
 ip address 172.16.1.194 255.255.255.224
 clock rate 128000
!
interface Serial0/1/1
 description R11 from R12
 ip address 192.168.240.65 255.255.255.192
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 172.16.1.96 0.0.0.31 area 0
 network 172.16.1.192 0.0.0.31 area 0
 network 172.16.1.128 0.0.0.31 area 0
 network 192.168.240.64 0.0.0.63 area 1
!
ip classless
!
no cdp run
!
banner motd ^C This R11 Step Two HOPS BACK!!^C
!
line con 0
 login local
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
----------------------------------------------------

 

R12

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R12
!
enable secret labbook123
!
username cisco privilege 15 password 0 cisco
!
spanning-tree mode pvst
!
interface Loopback1
 ip address 192.168.240.129 255.255.255.252
!
interface Loopback2
 ip address 192.168.240.133 255.255.255.252
!
interface Loopback3
 ip address 192.168.240.137 255.255.255.252
!
interface Loopback4
 ip address 192.168.240.141 255.255.255.252
!
interface Loopback5
 ip address 192.168.240.145 255.255.255.252
!
interface Loopback6
 ip address 192.168.240.149 255.255.255.252
!
interface Loopback7
 ip address 192.168.240.153 255.255.255.252
!
interface Loopback8
 ip address 192.168.240.157 255.255.255.252
!
interface Loopback9
 ip address 192.168.240.161 255.255.255.252
!
interface Loopback10
 ip address 192.168.240.165 255.255.255.252
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 description R12 to R11
 ip address 192.168.240.66 255.255.255.192
 clock rate 128000
!
interface Serial0/0/1
 description R12 to R9
 ip address 192.168.240.2 255.255.255.192
 clock rate 128000
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 192.168.240.64 0.0.0.63 area 1
 network 192.168.240.0 0.0.0.63 area 1
 network 192.168.240.128 0.0.0.63 area 1
!
ip classless
!
banner motd ^C R12 This is the final warning!!
banner motd ^C
!
line con 0
 login local
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
----------------------------------------------------

 

R13

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R13
!
enable secret labbook123
!
username cisco privilege 15 password 0 cisco
!
ip host R13 10.10.10.129
!
spanning-tree mode pvst
!
interface FastEthernet0/0
 description R13 connected to R1
 ip address 10.10.10.66 255.255.255.192
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 description R13 From R4
 ip address 10.10.10.129 255.255.255.192
!
interface Serial0/0/1
 no ip address
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 192.168.1.0 255.255.255.0 10.10.10.130
ip route 10.10.20.0 255.255.255.0 10.10.10.65
ip route 10.10.10.0 255.255.255.192 10.10.20.2
ip route 172.16.1.0 255.255.255.0 10.10.10.2
ip route 192.168.240.0 255.255.255.0 10.10.10.2
!
no cdp run
!
banner motd ^CBackbone R13 Speaking who is it^C
!
line con 0
 login local
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
end
----------------------------------------------------

 

SWITCH1

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch1
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
 no ip address
 shutdown
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
end
----------------------------------------------------

 

SWITCH2

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch2
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
 no ip address
 shutdown
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
end

 

Read 2395 times
Published in CCNA