CCNA CERT - VTP CONFIGURATION

 

 

This LAB presents the configuration of the proprietary protocol VTP (Vlan Trunking Protocol) of Cisco. This protocol is used from Cisco switches for VLANs 

The configuration was implemented according to the topology showing the image.

 

Switch Model:   Cisco switch  2960G
Version IOS: 14.x
Subject: Configure VTP protocol on Cisco Switches
Category LAB: CCNA EXAM

 

 

 

 

 

SW1

service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname SW1
!
enable secret labbook123
!
ip subnet-zero
no ip domain-lookup
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
interface Vlan1
 ip address 192.168.5.30 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.5.1
!
ip http server
!
line con 0
 exec-timeout 0 0
 password labbook123
 logging synchronous
 login
!
line vty 0 4
 password labbook123
 logging synchronous
 login
!
line vty 5 15
 password labbook123
 logging synchronous
 login
!
End
-------------------------------------------

 

 

SW2

service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname SW2
!
enable secret labbook123
!
ip subnet-zero
no ip domain-lookup
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
interface Vlan1
  ip address 192.168.5.10 255.255.255.0
!
ip default-gateway 192.168.5.1
ip http server
!
line con 0
 exec-timeout 0 0
 password labbook123
 logging synchronous
 login
!
line vty 0 4
 password labbook123
 logging synchronous
 login
!
line vty 5 15
 password labbook123
 logging synchronous
 login
!
End
-------------------------------------------

 

 

 

SW3

service password-encryption
hostname SW3
enable secret labbook123
no ip domain-lookup
!
interface Vlan1
ip address 192.168.5.20 255.255.255.0
!
ip default-gateway 192.168.5.1
ip http server
!
line con 0
 exec-timeout 0 0
 password labbook123
 logging synchronous
 login
!
line vty 0 4
 password labbook123
 logging synchronous
 login
!
line vty 5 15
 password labbook123
 logging synchronous
 login
!
end
-------------------------------------------

 

 

 

 

VTP  CONFIGURATION OF SW1

 

SW1(config)#vtp mode server

 Device mode already VTP SERVER.

SW1(config)#vtp domain LABBOOK

 Changing VTP domain name from NULL to LABBOOK  

SW1(config)#vtp password LABBOOK123

 Setting device VLAN database password to LABBOOK123

SW1(config)#vtp version 2

SW1(config)#vtp pruning 

SW1(config)#end

 

 

 

VTP  CONFIGURATION OF SW2

 

SW2(config)#vtp mode transparent

 Setting device to VTP TRANSPARENT mode.

SW2(config)#vtp domain LABBOOK

 Changing VTP domain name from NULL to LABBOOK

SW2(config)#vtp password LABBOOK123

 Setting device VLAN database password to LABBOOK123

SW2(config)#vtp version 2

SW2(config)#end

 

 

 

 

VTP  CONFIGURATION OF SW3

 

SW3(config)#vtp mode client

 Setting device to VTP CLIENT mode.

 SW3(config)#vtp domain LABBOOK

 Changing VTP domain name from NULL to LABBOOK

SW3(config)#vtp password LABBOOK123

 Setting device VLAN database password to LABBOOK123

 SW3(config)#vtp version 2

SW3(config)#end

-------------------------------------------

 

 

 

R1

service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R1
!
enable secret labbook123
!
interface FastEthernet0/0
ip address 192.168.5.1 255.255.255.0
no shutdown
!
no ip http server
no ip http secure-server
!
line con 0
 exec-timeout 0 0
 password labbook123
 logging synchronous
 login
!
line vty 0 4
 password labbook123
 logging synchronous
 login
!
end

 

 

 

 

Read 1915 times
Published in CCNA