ROUTER – ADSL PPoA

The LAB presents the configuration of the ADSL on a Cisco Router in order to connect to the Internet via ADSL line.

The configuration is based on the PPoA (PPP over ATM interface).

The configuration was implemented according to the topology showing the image.  

Router Model:   Cisco 886-K9 
Version IOS: 15.x
Subject: Configure ADSL over PPoA
Category LAB: Service Provider

 

 

 


hostname HOME-ROUTER
!
!

interface ATM0

no ip address

atm vc-per-vp 64

no atm ilmi-keepalive

pvc 8/35

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

no shutdown

!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface Vlan1
 description *** Connected to Internal Network 192.168.1.0/24 ***
 ip address 192.168.1.1 255.255.255.0
 ip nat inside    
 ip virtual-reassembly in
 no shutdown
!
interface Dialer1
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap pap callin
 ppp chap hostname labbook@otenet.gr
 ppp chap password 0 labbook123
 ppp pap sent-username labbook@otenet.gr password 0 labbook123
 ppp ipcp dns request accept
 ppp ipcp route default
 ppp ipcp address accept
 no cdp enable
 no shutdown
!
!
ip nat inside source list 102 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 102 permit ip 192.168.1.0 0.0.0.255 any
no cdp run
!
!
control-plane
!
!
!
end

-----------------------

Read 6072 times
Published in Service Provider