IPv6 to IPv4 TUNNELING CONFIGURATION

This lab is uploaded from user PanosP

 

 

Not all networks support dual-stack, tunnelling is used to transfer IPv6 traffic across an existing IPv4 networks. Many current internet users do not have IPv6 dual-stack support, and thus cannot reach IPv6 sites directly. Instead, they must use IPv4 infrastructure to carry IPv6 packets. This is done using a technique known as tunnelling, which encapsulates IPv6 packets within IPv4, in effect using IPv4 as a link layer for IPv6.

There are basic two types of IPv6 tunnels, manual, automatic. The primary difference in these tunnelling techniques is the method in which the tunnel source and destination are determined.

 

Manual Tunnels:

Manual tunnels must be configured manually. These tunnels are used when using IPv6 addresses that do not have any embedded IPv4 information. The IPv6 and IPv4 addresses of the endpoints of the tunnel must be specified.

Automatic tunnels:

Automatic tunnels are configured by using IPv4 address information embedded in an IPv6 address – the IPv6 address of the destination host includes information about which IPv4 address the packet should be tunnelled to.

The configuration of manually configured tunnels for IPv6 is self-explanatory. It requires definite specification of the tunnel IPv4 source and the tunnel IPv4 destination. The only drawback of when you use this technique is the amount of administration you must perform when the number of tunnels grows.

 

 

 

 R1

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
ipv6 unicast-routing
!
spanning-tree mode pvst
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Tunnel1
 no ip address
 mtu 1476
 ipv6 address 3000:1::1/64
 ipv6 rip CCNA enable
 tunnel source FastEthernet0/1
 tunnel destination 10.1.2.2
 tunnel mode ipv6ip
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2002:1::1/64
 ipv6 rip CCNA enable
!
interface FastEthernet0/1
 ip address 10.1.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 version 2
 network 10.0.0.0
!
ipv6 router rip CCNA
!
ip classless
!
no cdp run
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

----------------------------------------------------------

 

 

 

R2

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
ipv6 unicast-routing
!
spanning-tree mode pvst
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 ipv6 address 2001::1/128
 ipv6 rip RIPNG enable
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.0
!
interface Tunnel0
 no ip address
 mtu 1476
 ipv6 rip RIPNG enable
 ipv6 enable
 tunnel source Loopback1
 tunnel destination 3.3.3.3
 tunnel mode gre ip
!
interface FastEthernet0/0
 ip address 10.1.1.254 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 10.1.2.1 255.255.255.252
!
router eigrp 123
 network 192.168.12.0
 network 1.0.0.0
 no auto-summary
!
router rip
 version 2
 network 10.0.0.0
!
ipv6 router rip RIPNG
!
ip classless
!
no cdp run
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

----------------------------------------------------------

 

 

R3

version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
ip cef
ipv6 unicast-routing
!
no ipv6 cef
!
spanning-tree mode pvst
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Tunnel1
 no ip address
 mtu 1476
 ipv6 address 3000:1::3/64
 ipv6 rip CCNA enable
 tunnel source Serial0/0/0
 tunnel destination 10.1.1.1
 tunnel mode ipv6ip
!
interface Tunnel2
 no ip address
 mtu 1476
 ipv6 address 3000:2::3/64
 ipv6 rip CCNA enable
 tunnel source Serial0/0/1
 tunnel destination 10.1.3.2
 tunnel mode ipv6ip
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2002:2::1/64
 ipv6 rip CCNA enable
 ipv6 enable
!
interface Serial0/0/0
 ip address 10.1.2.2 255.255.255.252
 clock rate 2000000
!
interface Serial0/0/1
 ip address 10.1.3.1 255.255.255.252
 clock rate 2000000
!
router eigrp 123
 network 192.168.12.0
 network 192.168.23.0
 no auto-summary
!
router rip
 version 2
 network 10.0.0.0
!
ipv6 router rip CCNA
!
ip classless
!
ip flow-export version 9
!
no cdp run
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

 

----------------------------------------------------------

 

 

R4

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R4
!
ipv6 unicast-routing
!
spanning-tree mode pvst
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 ipv6 address 2001::3/128
 ipv6 rip RIPNG enable
!
interface Loopback1
 ip address 3.3.3.3 255.255.255.0
!
interface Tunnel0
 no ip address
 mtu 1476
 ipv6 rip RIPNG enable
 ipv6 enable
 tunnel source Loopback1
 tunnel destination 1.1.1.1
 tunnel mode gre ip
!
interface Tunnel2
 no ip address
 mtu 1476
 ipv6 address 3000:2::4/64
 ipv6 rip CCNA enable
 tunnel source Serial0/0/0
 tunnel destination 10.1.3.1
 tunnel mode ipv6ip
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2002:3::1/64
 ipv6 rip CCNA enable
!
interface Serial0/0/0
 ip address 10.1.3.2 255.255.255.252
!
router eigrp 123
 network 192.168.23.0
 network 3.0.0.0
 no auto-summary
!
router rip
 version 2
 network 10.0.0.0
!
ipv6 router rip RIPNG
!
ipv6 router rip CCNA
!
ip classless
!
no cdp run
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

 

 

Read 2118 times
Published in Routing