WAN CLOUD USING FRAME RELAY and MULTIAREA OSPF

This lab is uploaded from user PanosP

 

 

 

 

 

WAN Cloud with Frame-Relay using EIGRP to connect VLSM LANs, which they are on different OSPF areas

 

In this lab we are showing how to configure OSPF routing protocol in combination with EIGRP routing protocol to connect multiple OSPF areas. As you can see from the network topology diagram we have three OSPF areas that are not directly connected to a backbone area, but through a WAN Cloud Frame-Relay that using EIGRP. In each OSPF area are three VLSM LANs using OSPF routing protocol.

 

 

 

Learning Objectives:

  • Understand and configure OSPF design
  • Understand and configure EIGRP design
  • Understand and configure Frame-Relay
  • Understand and configure VLSM LANs
  • Configure Frame-Relay to connect OSPF areas

 

Tasks:

  1. Configure router hostnames on all routers
  2. Configure IP addresses on Gigabit Ethernet interfaces of all routers as shown on the network diagram
  3. Configure IP addresses on Serial interfaces of all routers as shown on the network diagram
  4. Configure Frame-Relay on serial ports and sublinks as shown on the Frame-Relay Configuration diagram
  5. Configure all LAN routers to be part of the OSPF routing process 10
  6. Configure routers R1, R2 and R3 to be part of the EIGRP routing process 10
  7. Configure routers R1, R2 and R3 to advertise network 10.1.1.0/24 as EIGRP process 10
  8. Configure routers R1, R2 and R3 to advertise the networks to the LANs as OSPF process 100
  9. Advertise LAN1 networks as OSPF area 2
  10. Advertise LAN2 networks as OSPF area 0
  11. Advertise LAN3 networks as OSPF area 1
  12. Verify OSPF routes
  13. Verify EIGRP routes
  14. Verify Frame-Relay
  15. Redistribute EIGRP routes into OSPF
  16. Redistribute OSPF routes into EIGRP
  17. Verify full connectivity from and to all end devices

 

 

 

 

 

FRAME RELAY CONFIGURATION

 

 

 

NETWORKS

Device Interface IP Address Mask Default Gateway
R1 Serial0/0/0 10.1.1.1 255.255.255.0 N/A
  Serial0/0/1 209.170.120.194 255.255.255.252 N/A
         
R2 Serial0/0/0 10.1.1.2 255.255.255.0 N/A
  Serial0/0/1 209.169.68.86 255.255.255.252 N/A
         
R3 Serial0/0/0 10.1.1.3 255.255.255.0 N/A
  Serial0/0/1 209.175.180.201 255.255.255.252 N/A
         
NET1 Serial0/0/0 209.170.120.193 255.255.255.252 N/A
  GigabitEthernet0/0 195.175.105.33 255.255.255.240 N/A
  GigabitEthernet0/1 195.175.105.49 255.255.255.248 N/A
  GigabitEthernet0/2 195.175.105.57 255.255.255.252 N/A
         
NET2 Serial0/0/0 209.169.68.85 255.255.255.252 N/A
  GigabitEthernet0/0 172.16.4.129 255.255.255.192 N/A
  GigabitEthernet0/1 172.16.4.193 255.255.255.224 N/A
  GigabitEthernet0/2 172.16.4.225 255.255.255.240 N/A
         
NET3 Serial0/0/0 209.175.180.202 255.255.255.252 N/A
  GigabitEthernet0/0 169.254.10.1 255.255.255.128 N/A
  GigabitEthernet0/1 169.254.10.129 255.255.255.192 N/A
  GigabitEthernet0/2 169.254.10.193 255.255.255.192 N/A
         
PC_A   195.175.105.34 255.255.255.240 195.175.105.33
PC_B   195.175.105.58 255.255.255.252 195.175.105.57
PC_C   195.175.105.50 255.255.255.248 195.175.105.49
PC_D   172.16.4.130 255.255.255.192 172.16.4.129
PC_E   172.16.4.194 255.255.255.224 172.16.4.193
PC_F   172.16.4.226 255.255.255.240 172.16.4.225
PC_K   169.254.10.2 255.255.255.128 169.254.10.1
PC_L   169.254.10.190 255.255.255.192 169.254.10.129
PC_M   169.254.10.194 255.255.255.192 169.254.10.193

 

 

NET1

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname NET1
!
ip cef
no ipv6 cef
!
no ip domain-lookup
ip domain-name LabBook.gr
!
spanning-tree mode rapid-pvst
!
interface GigabitEthernet0/0
 description **10 Hosts**Private Net**
 ip address 195.175.105.33 255.255.255.240
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description **5 Hosts**Private Net**
 ip address 195.175.105.49 255.255.255.248
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 description **2 Hosts**Private Net**
 ip address 195.175.105.57 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/0/0
 description **2 Hosts - Connected to R1**Public Net**
 ip address 209.170.120.193 255.255.255.252
 clock rate 2000000
!
router ospf 10
 log-adjacency-changes
 network 195.175.105.32 0.0.0.15 area 2
 network 195.175.105.48 0.0.0.7 area 2
 network 195.175.105.56 0.0.0.3 area 2
 network 209.170.120.192 0.0.0.3 area 2
!
ip classless
!
ip flow-export version 9
!
banner motd 
******************************************************
************ AUTHORISED ACCESS REQUIRED **************
******************************************************
* Unathorised access to this device is prohibited.   *
* You must have explicit permission to access this   *
* device. Any violation of access policy will result *
* in disciplinary action. !
line con 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line aux 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line vty 0 4
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
line vty 5 15
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
end

----------------------------------------------------------------

 

 

 

NET2

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname NET2
!
ip cef
no ipv6 cef
!
no ip domain-lookup
ip domain-name LabBook.gr
!
spanning-tree mode rapid-pvst
!
interface GigabitEthernet0/0
 description **40 Hosts**Private Net**
 ip address 172.16.4.129 255.255.255.192
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description **25 Hosts**Private Net**
 ip address 172.16.4.193 255.255.255.224
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 description **12 Hosts**Private Net**
 ip address 172.16.4.225 255.255.255.240
 duplex auto
 speed auto
!
interface Serial0/0/0
 description **2 Hosts - Connected to R2**Public Net**
 ip address 209.169.68.85 255.255.255.252
 clock rate 2000000
!
router ospf 10
 log-adjacency-changes
 network 172.16.4.128 0.0.0.63 area 0
 network 172.16.4.192 0.0.0.31 area 0
 network 172.16.4.224 0.0.0.15 area 0
 network 209.169.68.84 0.0.0.3 area 0
!
ip classless
!
ip flow-export version 9
!
banner motd 
******************************************************
************ AUTHORISED ACCESS REQUIRED **************
******************************************************
* Unathorised access to this device is prohibited.   *
* You must have explicit permission to access this   *
* device. Any violation of access policy will result *
* in disciplinary action.                            *
****************************************************** 
!
line con 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line aux 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line vty 0 4
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
line vty 5 15
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
end

--------------------------------------------------------------

 

 

NET3

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname NET3
!
ip cef
no ipv6 cef
!
no ip domain-lookup
ip domain-name LabBook.gr
!
spanning-tree mode rapid-pvst
!
interface GigabitEthernet0/0
 description **120 Hosts**Private Net**
 ip address 169.254.10.1 255.255.255.128
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description **60 Hosts**Private Net**
 ip address 169.254.10.129 255.255.255.192
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 description **40 Hosts**Private Net**
 ip address 169.254.10.193 255.255.255.192
 duplex auto
 speed auto
!
interface Serial0/0/0
 description **2 Hosts - Connected to R3**Public Net**
 ip address 209.175.180.202 255.255.255.252
 clock rate 2000000
!
router ospf 10
 log-adjacency-changes
 network 169.254.10.0 0.0.0.127 area 1
 network 169.254.10.128 0.0.0.63 area 1
 network 169.254.10.192 0.0.0.63 area 1
 network 209.175.180.200 0.0.0.3 area 1
!
ip classless
!
ip flow-export version 9
!
no cdp run
!
banner motd 
******************************************************
************ AUTHORISED ACCESS REQUIRED **************
******************************************************
* Unathorised access to this device is prohibited.   *
* You must have explicit permission to access this   *
* device. Any violation of access policy will result *
* in disciplinary action. !
line con 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line aux 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line vty 0 4
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
line vty 5 15
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
end

------------------------------------------------------

 

 

R1

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
ip cef
no ipv6 cef
!
no ip domain-lookup
ip domain-name LabBook.gr
!
spanning-tree mode rapid-pvst
!
interface Serial0/0/0
 description **Connected to WAN_Frame-Relay**
 ip address 10.1.1.1 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 10.1.1.2 102 broadcast
 frame-relay map ip 10.1.1.3 103 broadcast
 ip ospf network broadcast
 ipv6 ospf cost 781
!
interface Serial0/0/1
 description **2 Hosts - Connected to NET1**Public Net**
 ip address 209.170.120.194 255.255.255.252
 ipv6 ospf cost 781
 clock rate 128000
!
router eigrp 10
 redistribute ospf 100 metric 1 1 1 1 1
 network 209.170.120.192 0.0.0.3
 network 10.1.1.0 0.0.0.255
 no auto-summary
!
router ospf 100
 log-adjacency-changes
 redistribute eigrp 10 subnets
 network 209.170.120.192 0.0.0.3 area 2
!
ip classless
!
ip flow-export version 9
!
no cdp run
!
banner motd 
******************************************************
************ AUTHORISED ACCESS REQUIRED **************
******************************************************
* Unathorised access to this device is prohibited.   *
* You must have explicit permission to access this   *
* device. Any violation of access policy will result *
* in disciplinary action. !
line con 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line aux 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line vty 0 4
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
line vty 5 15
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
end

----------------------------------------------------------

 

 

R2

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
ip cef
no ipv6 cef
!
no ip domain-lookup
ip domain-name LabBook.gr
!
spanning-tree mode rapid-pvst
!
interface Serial0/0/0
 description **Connected to WAN_Frame-Relay**
 ip address 10.1.1.2 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 10.1.1.1 201 broadcast
 frame-relay map ip 10.1.1.3 203 broadcast
 ip ospf network broadcast
 ipv6 ospf cost 781
 clock rate 2000000
!
interface Serial0/0/1
 description **2 Hosts - Connected to NET2**Public Net**
 ip address 209.169.68.86 255.255.255.252
 ipv6 ospf cost 781
 clock rate 128000
!
router eigrp 10
 redistribute ospf 100 metric 1 1 1 1 1
 network 10.1.1.0 0.0.0.255
 no auto-summary
!
router ospf 100
 log-adjacency-changes
 redistribute eigrp 10 subnets
 network 209.169.68.84 0.0.0.3 area 0
!
ip classless
!
ip flow-export version 9
!
banner motd 
******************************************************
************ AUTHORISED ACCESS REQUIRED **************
******************************************************
* Unathorised access to this device is prohibited.   *
* You must have explicit permission to access this   *
* device. Any violation of access policy will result *
* in disciplinary action. !
line con 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line aux 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line vty 0 4
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
line vty 5 15
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
end

--------------------------------------------------

 

 

R3

no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
ip cef
no ipv6 cef
!
no ip domain-lookup
ip domain-name LabBook.gr
!
spanning-tree mode rapid-pvst
!
interface Serial0/0/0
 description **Connected to WAN_Frame-Relay**
 ip address 10.1.1.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 10.1.1.1 301 broadcast
 frame-relay map ip 10.1.1.2 302 broadcast
 ip ospf network broadcast
 ipv6 ospf cost 781
!
interface Serial0/0/1
 description **2 Hosts - Connected to NET3**Public Net**
 ip address 209.175.180.201 255.255.255.252
 ipv6 ospf cost 781
 clock rate 128000
!
router eigrp 10
 redistribute ospf 100 metric 1 1 1 1 1
 network 10.1.1.0 0.0.0.255
 no auto-summary
!
router ospf 100
 log-adjacency-changes
 redistribute eigrp 10 subnets
 network 209.175.180.200 0.0.0.3 area 1
!
ip classless
!
ip flow-export version 9
!
banner motd 
******************************************************
************ AUTHORISED ACCESS REQUIRED **************
******************************************************
* Unathorised access to this device is prohibited.   *
* You must have explicit permission to access this   *
* device. Any violation of access policy will result *
* in disciplinary action.                            *
****************************************************** 
!
line con 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line aux 0
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
line vty 0 4
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
line vty 5 15
 exec-timeout 5 0
 password cisco
 logging synchronous
 login
!
end

 

 

 

 

 

Read 1856 times
Published in Service Provider